首页 > 选股公式 > 通达信公式 > 正文

通达信换手率战法指标公式(选股公式/源码)

2020-12-30 03:12:17 来源:网络

最近看到很多股民说需要通达信公式里关于通达信换手率战法指标公式,下面红股网整理一份《通达信换手率战法指标公式(选股公式/源码)》,希望让您对通达信公式有所认识。

正能量:VOL,VOLSTICK,COLORRED;

负能量:-VOL,VOLSTICK,COLORCYAN;

年换手:SUM(VOL,YEAR)*100/CAPITAL,NODRAW;

月换手:SUM(VOL,MONTH)*100/CAPITAL,NODRAW;

周换手:SUM(VOL,WEEKDAY)*100/CAPITAL,NODRAW;

日换手:IF((SETCODE==0||SETCODE==1),100*VOL,VOL)/(FINANCE(7)/100),NODRAW;

多头换手:SUM(ACTINVOL,1)*100/CAPITAL,NODRAW,COLORYELLOW;

空头换手:SUM(ACTOUTVOL,1)*100/CAPITAL,NODRAW,COLORGREEN;

五十换手:SUM(VOL,50)*100/CAPITAL,NODRAW;

百日换手:SUM(VOL,100)*100/CAPITAL,NODRAW;

{年月日星期}

DA:=YEAR AND MONTH AND DAY;

AA1:=STRCAT(CON2STR(YEAR,0),'年');

AA2:=STRCAT(CON2STR(MONTH,0),'月');

AA3:=STRCAT(CON2STR(DAY,0),'日');

AA4:=STRCAT('【',IF(WEEKDAY=1,'星期一',IF(WEEKDAY=2,'星期二',

IF(WEEKDAY=3,'星期三',IF(WEEKDAY=4,'星期四',IF

(WEEKDAY=5,'星期五',IF(WEEKDAY=6,'星期六','星期日')))))));

AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'】');

DRAWTEXT_FIX(DA,0.88,0.991,0,AA),COLORWHITE;

SAT:=(DVOL/DCLOSE)/(HHV(DVOL,20)/HHV(DCLOSE,20));

当期量能饱和:=(IF(SAT>1,1,SAT)*100);

DRAWTEXT_FIX(1,0.991,0.001,1,STRCAT(STRCAT('当期量能饱和: ',CON2STR(当期量能饱和,2)),'%')),COLORRED;

DRAWTEXT_FIX(ISLASTBAR=1,0.0100,0,0,STKNAME), COLOR0000FF;

DRAWTEXT_FIX(ISLASTBAR=1,0.0880,0,0,CODE),COLORWHITE;

ASDF:=STRCAT(STRCAT('当前获利盘比例: ',CON2STR(WINNER(CLOSE)*100,2)),'%');

DRAWTEXT_FIX(ISLASTBAR,0.300,0.010,0,ASDF),COLORWHITE;

{ASDF1:=STRCAT(STRCAT('昨日获利盘比例: ',CON2STR(WINNER(REF(CLOSE,1))*100,2)),'%');}

{DRAWTEXT_FIX(ISLASTBAR,0.700,0.010,0,ASDF1),COLORYELLOW;}

LC:=REF(CLOSE,1);

WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;

WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;

活跃:=(WRSI-WR10);

活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2));

DRAWTEXT_FIX(1,0.707,0.01,1,STRCAT(STRCAT('活跃度比: ',CON2STR(活跃度比,2)),'%')),COLORCYAN;

毛利比率:=(HHV(H,0)-LLV(L,0))/LLV(L,0)*100*0.44,NODRAW,COLORYELLOW;

DRAWTEXT_FIX(1,0.82800,0.01,1,STRCAT(STRCAT('毛利比率: ',CON2STR(毛利比率,2)),'%')),COLORYELLOW;

A111:=FINANCE(42);

A211:=DATETODAY(CONST(DATE));

A311:=A211-A111;

XDATE:=DAYTODATE(A311)+19000000;

上市日期:=STRCAT(' 上市日期: ',CON2STR(XDATE,0));

DRAWTEXT_FIX(ISLASTBAR,0.45,0,0,上市日期),COLORMAGENTA;

SSTS1:=STRCAT('上市',CON2STR(FINANCE(42),0));

SSTS2:=STRCAT(SSTS1,'天');

{DRAWTEXT_FIX(CURRBARSCOUNT=1,0.618,0.0,0,SSTS2),COLORCYAN;}

SSTS3:=STRCAT('累计交易:',CON2STR(TOTALBARSCOUNT,0));

SSTS4:=STRCAT(SSTS3,'周期');

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.168,0.001,0,SSTS4),COLORLIMAGENTA;

{涨停统计}

W11:=EMA(C,1);

涨停:=W11/REF(W11,1)>=1.095;

ZTCS:=COUNT(涨停,BARSSINCE(涨停)+1);

NTZZT1:=STRCAT('  距今',CON2STR(CONST(BARSLAST(涨停)),0));

NTZZT2:=STRCAT(NTZZT1,'天有涨停');

GZT1:=STRCAT('  共涨停',CON2STR(ZTCS,0));GZT2:=STRCAT(GZT1,'次');

ZTTJ1:=STRCAT(SSTS2,GZT2);

ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);ZTTJ:=STRCAT('【涨停统计】',ZTTJ2);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.618,0.99,0,ZTTJ),COLORCYAN;

Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,FGBLOCK);

Z3:=STRCAT(Z2,DYBLOCK);

Z4:=STRCAT(Z3,' ');

HSL11:=V/CAPITAL*100;

DRAWNUMBER(CURRBARSCOUNT=1 AND HSL11,L,HSL11),COLOR00FFFF;

DRAWTEXT_FIX(ISLASTBAR,0.00,0.991,0,STRCAT(Z4,GNBLOCK)),COLORGREEN;

DRAWTEXT_FIX(1,0.500,0.991,0,STRCAT('【自定板块】:',ZDBLOCK)),COLORYELLOW;

以上是由“红股网”整理的“通达信换手率战法指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱85703630@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。