首页 > 选股公式 > 同花顺公式 > 正文

同花顺顶底之间指标公式(选股公式/源码)

2020-12-26 04:48:43 来源:网络

最近看到很多股民说需要同花顺公式里关于同花顺顶底之间指标公式,下面红股网整理一份《同花顺顶底之间指标公式(选股公式/源码)》,希望让您对同花顺公式有所认识。

折线:ZIG(3,20);

前波峰值:=PEAK(3,20,1);

前波谷值:=TROUGH(3,20,1);

DRAWNUMBER(折线>REF(折线,1) AND REF(折线,1)<REF(折线,2),REF(C,1),-(前波峰值-REF(C,1))/前波峰值*100);

DRAWNUMBER(折线<REF(折线,1) AND REF(折线,1)>REF(折线,2),REF(C,1),(REF(C,1)-前波谷值)/前波谷值*100);

VAR1:=ZIG(3,2.88)<REF(ZIG(3,2.88),1) AND REF(ZIG(3,2.88),1)>REF(ZIG(3,2.88),2);

VAR2:=ZIG(3,2.88)>REF(ZIG(3,2.88),1) AND REF(ZIG(3,2.88),1)<REF(ZIG(3,2.88),2);

STICKLINE(VAR1,C,O,8,0),COLOR00FF00;

STICKLINE(VAR1,C,O,5,0),COLOR00FF00;

STICKLINE(VAR1,H,L,2,0),COLOR00FF00;

STICKLINE(VAR2,C,O,7,0),COLOR0000FF;

STICKLINE(VAR2,C,O,5,0),COLOR0000FF;

STICKLINE(VAR2,H,L,2,0),COLOR0000FF;

X1:=(C+L+H)/3;

X2:=EMA(X1,6);

X3:=EMA(X2,5);

STICKLINE(CROSS(X2,X3),OPEN,CLOSE,6,0),coloryellow;

STICKLINE(CROSS(X3,X2),OPEN,CLOSE,6,0),colorblue;

B:EMA(C,2),POINTDOT,color000000;

W:ZIG(1,3),coloryellow;

G:=MA(W,2),colorred;

D:=EMA(W,34),colorgreen;

F:=100*(C-REF(C,1))/REF(C,1);

JD:=IF(C<REF(O,1) AND F<0,1,0);

S1:=JD;

MR:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;

S2:=MR;

A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));

A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));

AA:=(CROSS(W,G) AND (A1 AND A2 OR D<0)) OR CROSS(B,G);

A11:LLV(LOW,144),colormagenta;

STICKLINE(A11<W AND W>REF(W,1),W,A11,9,0),colorbrown,LINETHICK5;

STICKLINE(A11<B AND W<REF(W,1),W,A11,0.8,0),colorgreen;

A11,colorgray,LINETHICK7;

B:ZIG(3,10),coloryellow;

G:=MA(B,2),colorred;

D:=EMA(B,34),colorgreen;

J:=EMA(B,144),colorligreen;

DRAWICON(CROSS(B,G),B-0.1,1);

DRAWICON(CROSS(G,B),G+0.1,2);

//DRAWTEXT(CROSS(B,G),B*0.85,"建"),coloryellow;

//DRAWTEXT(CROSS(G,B),G,"清"),colorgreen;

F:=100*(C-REF(C,1))/REF(C,1);

JD:=IF(C<REF(O,1) AND F<0,1,0);

S1:=JD;

MR:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0;

S2:=MR;

A1:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,3) ,REF(ZIG(3 ,3),1));

A2:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1));

//DRAWTEXT(A1 AND A2 OR D<0,B,'加仓'),coloryellow;//加仓买

//DRAWICON(A1 AND A2,B-0.2,1);

VAR3:=PEAKBARS(3,5,1)<10;

VAR5:=IF(VAR3=1,2,0);

顶:= IF(VAR5=2,2,0);

顶A:=IF(顶>REF(顶,1),1,0),STICK,colorcyan, LINETHICK2;//

//DRAWTEXT(顶A=1,B*1.1,'减仓'),colorgreen;

DRAWICON(顶A=1,B,2);

MID:=MA(CLOSE,26);

UPPER:=MID + 2*STD(CLOSE,26),colorwhite;//上轨

UPPER1:=MID + 1.618*STD(CLOSE,26),colorred;//上轨

LOWER:=MID - 2*STD(CLOSE,26),coloryellow;//下轨

LOWER1:=MID - 1.618*STD(CLOSE,26),colorgreen;//下轨

//DRAWTEXT(CROSS(CLOSE,LOWER),J*1.05,"L"),coloryellow;;

//DRAWTEXT(CROSS(CLOSE,UPPER),J*1.05,"L"),colorgreen;

VERLINE(CROSS(B,G) AND (A1 AND A2 OR D<0),1),colorlimagenta;//画加仓建仓垂线

VERLINE(CROSS(G,B),1),colorcyan;//画清仓垂线

买线:=ZIG(3,10);

卖线:=MA(买线,3);

STICKLINE(CROSS(买线,卖线),O,C,9,0),COLOR00AAFF;

STICKLINE(买线<卖线,H,L,0,0),colorgreen;

STICKLINE(买线<卖线,C,O,9,0),Color007700;

STICKLINE(买线<卖线,C,O,8,0),Color008E00;

STICKLINE(买线<卖线,C,O,7,0),Color009900;

STICKLINE(买线<卖线,C,O,6,0),Color00A600;

STICKLINE(买线<卖线,C,O,5,0),Color00B500;

STICKLINE(买线<卖线,C,O,4,0),Color00C600;

STICKLINE(买线<卖线,C,O,3,0),Color00D500;

STICKLINE(买线<卖线,C,O,2,0),Color00E600;

STICKLINE(买线>=卖线,H,L,0,0),Color0000FF;

STICKLINE(买线>=卖线,C,O,9,0),Color0000A3;

STICKLINE(买线>=卖线,C,O,8,0),Color0000B7;

STICKLINE(买线>=卖线,C,O,6,0),Color0000C8;

STICKLINE(买线>=卖线,C,O,5,0),Color0000D9;

STICKLINE(买线>=卖线,C,O,4,0),Color0000CD;

STICKLINE(买线>=卖线,C,O,3,0),Color0000E9;

STICKLINE(买线>=卖线,C,O,2,0),Color0000EA;

STICKLINE(买线>=卖线,C,O,1,0),Color0000FF;

Var10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

Var12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

Var13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

Var14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

Var15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

Var16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

Var18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

Var19:=EMA(CLOSE,2)-EMA(CLOSE,150);

Var1A:=EMA(Var19,100);

Var1B:=2*(Var19-Var1A);

Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);

Var1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

Var1E:=EMA(Var1D*0.97,3);

Var1F:=(HIGH+LOW+CLOSE)/3;

买点1:=Var10;

买点2:=(Var11+Var13+Var15+Var17);

VAR1:=MA(CLOSE,5);

VAR2:=MA(CLOSE,10);

VAR3:=MA(CLOSE,30);

VAR4:=MA(CLOSE,60);

VAR5:=EMA(COST(85),7);

VAR6:=EMA(COST(15),7);

VAR7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);

VAR8:=INTPART(VAR7*100)/100;

VAR9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);

VARA:=INTPART(VAR9*100)/100;

VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);

VARC:=INTPART(VARB*100)/100;

VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);

VARE:=EMA(VARD,9);

VAR13:=REF(VARE,1);

VAR14:=VARE;

VAR15:=VAR14-VAR13;

VAR16:=REF(VARD,1);

VAR19:=OPEN;

买点3:=IF(VAR19<=VAR1 AND VAR19<=VAR2 AND VAR19<=VAR3 AND VAR1A>=VAR1 AND VAR1A>=VARC AND VAR15>0 AND VAR18>0,0.5,0);

VERLINE(买点3>0 OR 买点1>0 OR 买点2>0, 2),Color0000ff;

A1:=C>=REF(C,4);

A:=C<REF(C,4);

AA:=C<REF(C,4) AND REF(A1,2);

T:=BARSLAST(AA),NODRAW;

N:=T=1 AND REF(T=0 AND AA,2) AND A;

N1:=T=2 AND REF(N,1) AND A;

N2:=T=3 AND REF(N1,1) AND A;

N3:=T=4 AND REF(N2,1) AND A;

N4:=T=5 AND REF(N3,1) AND A;

N5:=T=6 AND REF(N4,1) AND A;

N6:=T=7 AND REF(N5,1) AND A;

N7:=T=8 AND REF(N6,1) AND A;

DRAWTEXT(N5,H*1.10,'7'),colorred;

DRAWTEXT(N6,H*1.10,'8'),colorred;

DRAWTEXT(N7,H*1.10,'9'),colorred;

VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

寻底买进1:=VAR10;

买进2:=(VAR11+VAR13+VAR15+VAR17);

DRAWTEXT(寻底买进1>0 OR 买进2>0,LOW*1.19,'加仓'),colorred;

DRAWTEXT(寻底买进1>0 ,LOW*1.25,'寻底'),coloryellow;

以上是由“红股网”整理的“同花顺顶底之间指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱85703630@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。