首页 > 选股公式 > 大智慧公式 > 正文

大智慧提前信息MACD指标公式(选股公式/源码)

2020-10-30 06:51:09 来源:网络

最近看到很多股民说需要大智慧公式里关于大智慧提前信息MACD指标公式,下面红股网整理一份《大智慧提前信息MACD指标公式(选股公式/源码)》,希望让您对大智慧公式有所认识。

短线成本:EMA(CLOSE,17),LINETHICK2,COLORWHITE;

A:=(3*C+L+O+H)/6;

X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+

14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)

+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+

REF(A,20))/210;

中线成本:EMA(X,13),LINETHICK2,COLORFF00FF;

STICKLINE(BARSLAST(短线成本<中线成本)>30,95,100,5,0),COLORRED;

STICKLINE(BARSLAST(短线成本>中线成本)>30,0,5,5,0),COLORGREEN;

VAR1:=1;

VAR2:=LLV(LOW,10);

VAR3:=HHV(HIGH,25);

N1:=5;

N4:=34;

CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));

SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));

饱和度:=IF(SAT>1,1,SAT)*100;

W1:=C=HHV(C,20);

W2:=BARSLAST(W1);

W3:=IF(W2>0,REF(C,W2),REF(C,W2));

W4:=CROSS(C,REF(W3,1));

STICKLINE(饱和度>=97 AND CQ>90,0,100,2,0),COLORRED;

中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));

持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

支撑:=LLV(持股,3);

短期线:EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30,LINETHICK2,COLORGREEN;

中期线:MA(持股,12),COLORWHITE,LINETHICK2;

STICKLINE(支撑<中期线,支撑,中期线,2,0),COLOR6B8E23;

STICKLINE(持股>0,支撑,持股,2,0),COLORRED;

STICKLINE(支撑>中期线,中期线,支撑,2,0),COLOR38B0DE;

STICKLINE(支撑=持股 AND 持股>中期线,中期线,支撑,2,0),COLORFF00FF;

STICKLINE(REF(中期,1)<1 AND 中期>1,0,15,2,0),COLORWHITE;

STICKLINE(W4 AND COUNT(W4,5)=1,85,100,2,0),COLORYELLOW;

底部线:0,COLORWHITE;

警戒线:85,COLORYELLOW;

卖出线:100,COLORRED;

以上是由“红股网”整理的“大智慧提前信息MACD指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱85703630@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。