首页 > 选股公式 > 飞狐公式 > 正文

飞狐MACD与KDJ综合指标公式(选股公式/源码)

2020-10-07 03:53:22 来源:网络

最近看到很多股民说需要飞狐公式里关于飞狐MACD与KDJ综合指标公式,下面红股网整理一份《飞狐MACD与KDJ综合指标公式(选股公式/源码)》,希望让您对飞狐公式有所认识。

DIFZ:=EMA(C,12)-EMA(C,26);

DEAZ:=EMA(DIFZ,9);

MACDZ:=8*(DIFZ-DEAZ);

RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;

SQX:=(C-MA(CLOSE,13))*10;

DIF:=EMA(MA(SQX,7),1);

DEA:=EMA(DIF,7);

MACD:=(DIF-DEA)*2;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.1,0),COLORRED;

STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.1,0),COLORWHITE;

STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.1,0),COLORBLUE;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.1,0),COLORBROWN;

K:SMA(SMA( RSV,3,1),3,1),COLORWHITE;

D:MA(EMA(K,3),3),COLORYELLOW;

J:3*K-2*D,COLORMAGENTA;

A11:=BARSLAST(REF(CROSS(DIF,DEA),1));

B1:=REF(C,A11+1)>C AND REF(DIF,A11+1)<DIF AND CROSS(DIF,DEA);

A12:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));

B2:=REF(C,A12+1)>C AND REF("KDJ.K",A12+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");

A13:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));

B3:=REF(C,A13+1)>C AND REF("RSI.RSI1",A13+1)<"RSI.RSI1"AND CROSS("RSI.RSI1","RSI.RSI2");

C1:=BARSLAST(REF(CROSS(DEA,DIF),1));

D1:=REF(C,C1+1)<C AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF);

C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));

D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");

C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));

D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");

MACD底背:IF(B1>0,50,0),LINETHICK2,COLORRED;

DRAWTEXT(B1>0,50,'M底背'),COLORRED;

KDJ底背:IF(B2>0,65,0),LINETHICK2,COLORFF00FF;

DRAWTEXT(B2>0,65,'K底背'),COLORFF00FF;

RSI底背:IF(B3>0,80,0),LINETHICK2,COLORYELLOW;

DRAWTEXT(B3>0,80,'R底背'),COLORYELLOW;

MACD顶背:IF(D1>0,-50,0),LINETHICK2,COLOR00FF00;

DRAWTEXT(D1>0,-50,'M顶背'),COLOR00FF00;

KDJ顶背:IF(D2>0,-65,0),LINETHICK2,COLORFFCC66;

DRAWTEXT(D2>0,-65,'K顶背'),COLORFFCC66;

RSI顶背:IF(D3>0,-80,0),LINETHICK2,COLORWHITE;

DRAWTEXT(D3>0,-80,'R顶背'),COLORWHITE;

DRAWICON((CROSS(K,D)

AND K<0 ),REF(K,1),11);

DRAWICON((CROSS(D,K) AND K>0

),D*1.05,12);

DRAWICON(J<(REF(J,1))AND K>(REF(K,1)) AND D>(REF(D,1)

AND J>0),REF(J,1),2);

DRAWICON(J>REF(J,1) AND K<REF(K,1) AND

D<REF(D,1) AND J<0,REF(J,1),1);

DRAWICON(MACD<REF(MACD,1) AND

REF(MACD,1)>REF(MACD,2) AND

MACD>0,MACD,2);

DRAWICON(MACD>REF(MACD,1) AND

REF(MACD,1)<REF(MACD,2) AND MACD<=0,MACD,1);

多方趋势:((7)*(SMA(((CLOSE-LLV (LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(30),4,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(30),4,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(30),4,1),3,1),2,1)),COLOR0000FF;

空方趋势:(EMA(MA(多方趋势,5),7)),COLORF0F000;

STICKLINE((多方趋势>78) AND (多方趋势>=空方趋势),78,多方趋势,5,1),COLOR00FF00;

STICKLINE((空方趋势<=多方趋势),空方趋势,多方趋势,3,0),COLOR0000FF;

STICKLINE((空方趋势>多方趋势),多方趋势,空方趋势,3,0),COLORF0F000;

STICKLINE((空方趋势<14) AND (空方趋势>多方趋势),多方趋势,20,3,0),COLOR00FFFF;

TJ:=FILTER((空方趋势<14) AND (空方趋势>多方趋势),6);

DRAWTEXT(TJ,40,'低吸'),COLORFFFFFF;

斋主:(空方趋势<12) AND (空方趋势<=多方趋势),COLOR00FFFF;

选金股:CROSS(多方趋势,空方趋势) AND (空方趋势<22);

{E:=CROSS(83,RSI);

STICKLINE( E,75,85,4,0),COLOR00FF00;

DRAWTEXT(E,72,' 逃顶');}

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HD:=(HIGH - REF(HIGH,1));

LD:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

NEWVOL:=(RSI5 - WR10);

最佳买入:=(AV + NEWVOL);

最佳买入选股:IF(CROSS(最佳买入,0),61,0),STICK,COLORRED,LINETHICK4;

DRAWTEXT(CROSS(最佳买入,0),62,'最佳买入'),COLOR00FFFF;

AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;

BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;

CC:=EMA(AA,2);

DD:=EMA(BB,5);

TJ0:=CROSS(CC,DD);

上:=EMA(C,3);

中:=EMA(C,5);

下:=EMA(中,5);

TJ1:=CROSS(上,中);

TJ2:=上>REF(上,1);

X1:=(C+L+H)/3;

BB5:=ATAN(EMA(X1,5)-REF(EMA(X1,5),1))*3.1416*10;

EMA3:=EMA(C,3);

TJ3:=BB5>1 AND EMA(X1,5)>REF(EMA(X1,3),1);

STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,20,4,0)COLOR009999;

STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,35,3,0)COLOR00BBBB;

STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,45,1.5,0)COLOR00DDDD;

STICKLINE(TJ1 AND TJ2 AND TJ0 AND TJ3,0,50,0.6,0)COLOR00FFFF;

DRAWTEXT(TJ1 AND TJ2 AND TJ0 AND TJ3,48,'斋主全仓'),COLORRED;

{斋主全仓:IF(CROSS('斋主全仓',0),0.9,0),STICK,COLORRED;}

DRAWTEXT(CROSS(多方趋势,空方趋势) AND (空方趋势<22),30,'金股'),COLOR00FFFF;

中间线:50,COLORFFFFFF,POINTDOT;

VAR11:=(CLOSE+HIGH+LOW)/3;

VAR2A1:=EMA(VAR11,10);

VAR3A:=REF(VAR2A1,1);

绿珠逃:IF(VAR2A1,0.1,0),COLORGREEN,LINETHICK9;

红珠买: IF(VAR2A1>VAR3A,0.1,0),COLORRED,LINETHICK9;

黄珠卖: IF(VAR2A1<VAR3A,0.1,0),COLOR00FFFF,LINETHICK9;

以上是由“红股网”整理的“飞狐MACD与KDJ综合指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱85703630@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。