首页 > 选股公式 > 通达信公式 > 正文

通达信量里寻庄指标公式(选股公式/源码)

2020-09-16 06:44:34 来源:网络

最近看到很多股民说需要通达信公式里关于通达信量里寻庄指标公式,下面红股网整理一份《通达信量里寻庄指标公式(选股公式/源码)》,希望让您对通达信公式有所认识。

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));

成交:=VOL;

买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));

卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));

买卖差:=(买盘 + 卖盘);

STICKLINE((VOL > 0),VOL,0,2,1),COLORFFFFFF;

STICKLINE((买卖差 > 0),0,买卖差,2,0),COLOR0000FF;

STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,COLOR33FF33;

量比:=(VOL / MA(VOL,5));

VAR10:=买盘;

VAR20:=卖盘;

JX1:=BARSSINCE(买盘);

JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);

JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);

VAR30:=MA(VOL,JY2);

动神:=买盘;

鬼力:=VAR20;

神比:=(动神 / VAR30);

鬼比:=(鬼力 / VAR30);

VAR2:=(HIGH - LOW);

VAR3:=ABS((OPEN - CLOSE));

VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));

VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);

VAR6:=((VAR3 / VAR2) * VOL);

VAR7:=((VAR4 / VAR2) * VOL);

VAR8:=((VAR5 / VAR2) * VOL);

VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));

VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);

VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));

VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));

VARD:=REF(CLOSE,1);

VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);

DRAWTEXT(((DATE > 700101) AND CROSS(84,VARE)),HIGH,'■卖出'),COLORF2A3A4;

VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);

VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);

VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);

VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);

三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);

三日下攻:=MA(VAR50,JY2);

多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,4,1),COLOR0000FF;

空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,4,1),COLOR00FF00;

{STICKLINE((鬼力 > 0),鬼力,0,8,0),COLORFF3399;}

加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,3,0),COLOR00FFFF;

减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,3,0),COLORFF0000;

洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,3,0),COLORFFFFFF;

高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,3,0),COLORFF00FF;

相对地量:=STICKLINE(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),0,VOL,2,0);

地量:=DRAWTEXT(((VAR9 > 2) AND (VOL < (MA(VOL,5) / 2))),VOL,'地量');

放量:=STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2,0);

STICKLINE((动神 > 0),动神,0,1.5,0),COLOR0000FF;

上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);

下攻:=MA(VAR50,JY2);

上攻均量:=MA(VAR10,JY1);

下攻均量:=MA(VAR20,JY1);

逢高出货:=DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR9 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,'▼出货');

逢低跟进:=DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'●低进');

强势参与:=DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,'◆强势');

DRAWTEXT(((((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)) AND ((VAR6 / VOL) > 0.7)) AND VARC) AND (VAR6 > MA(VOL,5))),(VAR6 * 2),'▼空头'),COLOR00FF00;

DRAWTEXT((((((量比 > 1) AND ((动神 / 三日上攻) > 1.58)) AND IF((三日上攻 > 上攻均量),(三日上攻 > 三日下攻),(三日上攻 > REF(三日上攻,1)))) AND (三日下攻 < REF(三日下攻,1))) AND ((((CLOSE - REF(CLOSE,3)) / REF(CLOSE,3)) * 100) < 14)),(动神 * 1.3),'★逃顶'),COLOR99FF00;

MFI:=(((HIGH - LOW) * 1000000) / VOL);

换手率:DYNAINFO(37);

DRAWTEXT((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (换手率 > 1)),(VOL * 1.1),'●量变'),COLOR00FFFF;

量:IF((CLOSE > 200),(VOL / 1000000),(VOL / 100)),LINETHICK0;

振幅:(((HIGH - LOW) / LOW) * 100),LINETHICK0;

STICKLINE((((CLOSE >= OPEN) AND (换手率 >= 3)) AND

(换手率 < 5)),0,量,80,1),COLOR33AAFF;

AAA:=CONST(HHV(VOL,90));

A1:=IF(AAA=CONST(HHV(VOL,90)),0+0.05,0);

A2:=IF(AAA=CONST(HHV(VOL,90)),A1+0.05,0);

A3:=IF(AAA=CONST(HHV(VOL,90)),A2+0.05,0);

A4:=IF(AAA=CONST(HHV(VOL,90)),A3+0.05,0);

A5:=IF(AAA=CONST(HHV(VOL,90)),A4+0.05,0);

A6:=IF(AAA=CONST(HHV(VOL,90)),A5+0.05,0);

以上是由“红股网”整理的“通达信量里寻庄指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱hongguwang@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。