首页 > 选股公式 > 飞狐公式 > 正文

飞狐智能看盘主图指标公式(选股公式/源码)

2020-06-30 05:39:54 来源:网络

最近看到很多股民说需要飞狐公式里关于飞狐智能看盘主图指标公式,下面红股网整理一份《飞狐智能看盘主图指标公式(选股公式/源码)》,希望让您对飞狐公式有所认识。

VAR1:=(2*CLOSE+HIGH+LOW)/4;

VAR2:=IF(YEAR>=2099 AND MONTH>2,0,1);

VAR3:=LLV(LOW,5);

VAR4:=HHV(HIGH,4);

散户:=EMA((VAR1-VAR3)/(VAR4-VAR3)*100,4)*VAR2;

庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR2;

DRAWTEXT(CROSS(散户,庄家) AND 散户<47,L-0.05,'←低吸'),COLORLIRED;

DRAWTEXT(CROSS(庄家,散户) AND 散户>60,H+0.05,'←高抛'),COLOR80FF00;

DRAWICON(CROSS(散户,庄家) AND 散户<47,L-0.05,4);

DRAWICON(CROSS(庄家,散户) AND 散户>60,H+0.05,5);

市场成本:DMA(AMOUNT/V/100,V/CAPITAL),COLORyellow;

操盘成本:=(MA(C,30)+MA(C,72))/2,COLORRED;

市盈率:=DYNAINFO(39),COLORFF00FF;

TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;

STICKLINE(TJ,OPEN,CLOSE,3,0),COLORFF00FF;

量_价:=1;CTKG:=1;

W:=量_价;

EPSL:=0.0001;

ZZ:=(C+H+L)/3;

TJA:=ZZ>=MAX(C,O) AND CTKG=1;{倒锤头};

TJB:=ZZ<=MIN(C,O) AND CTKG=1;{正锤头};

ZF:=IF(TJA,1,IF(TJB,-1,0));{正负数};

TJ0:=TJA OR TJB;

TJ1:=H=L AND C>REF(C,1);{一字涨停};

TJ2:=H=L AND C<REF(C,1);{一字跌停};

TJ3:=H=L AND C=REF(C,1);{连续一字涨、跌停};

量_价:=IF(W=1,VOL,AMOUNT),STICK,COLOREEFFEE;{平盘量,白色}

EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));

ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));

JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;

差:=(JGL_DX*量_价)/20000,COLOR13AADD;

DX:=JGL_DX*100;

买:=量_价*(1+JGL_DX)/20000,COLOR1133AA;

卖:=量_价*(1-JGL_DX)/20000,COLORFFFF00;

量差:=买-卖,COLORYELLOW;

STICKLINE(量差<=0,CLOSE,OPEN,5,0),COLOR009900;

STICKLINE(量差<=0,CLOSE,OPEN,4,0),COLOR00BB00;

STICKLINE(量差<=0,CLOSE,OPEN,3,0),COLOR00DD00;

STICKLINE(量差<=0,CLOSE,OPEN,0.5,0),COLOR00FF00;

STICKLINE(量差>=0,CLOSE,OPEN,5,0),COLOR000099;

STICKLINE(量差>=0,CLOSE,OPEN,4,0),COLOR0000CC;

STICKLINE(量差>=0,CLOSE,OPEN,3,0),COLOR0000FF;

STICKLINE(量差>=0,CLOSE,OPEN,0.5,0),COLORCC66FF;

V2V:=V/REF(V,1)>=1.9 AND C>REF(C,1);

STICKLINE(V2V,OPEN,CLOSE,3,0),COLORYELLOW;

ZT:=C/REF(C,1)>1.097;

STICKLINE(ZT,OPEN,CLOSE,3,0),COLORYELLOW;

V3V:=V/REF(V,1)>=1.9 AND C<REF(C,1);

STICKLINE(V3V,OPEN,CLOSE,3,0),COLORBLUE;

D:=MA(CLOSE,80)-MA(CLOSE,10)/3;

DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08

AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'↖抄底'),COLORRED;

{WH1:=IF(L=LLV(L,9),L,0);

WH2:=CONST(BARSLAST(WH1!=0));

WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));

WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);

WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));

WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);

WH7:IF(CURRBARSCOUNT<=WH2+10,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED,DOTLINE;

STICKLINE(CURRBARSCOUNT<=WH2+1 AND L=LLV(L,9),O,C,3,0),COLORRED;

DRAWTEXT(CURRBARSCOUNT=WH2+10,WH7,'LINE'),COLORRED;

DRAWTEXT(ISLASTBAR,WH7,'进场线'),COLORRED;

WH8:IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,9),L,DRAWNULL),DRAWNULL),CIRCLEDOT;

H1:=IF(H=HHV(H,9),H,DRAWNULL);

H2:=CONST(BARSLAST(H1!=DRAWNULL));

H3:=CONST(IF(H2=0,L,REF(L,H2)));

H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);

H5:=CONST(IF(H4=0,L,REF(L,H4)));

H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);

H7:IF(CURRBARSCOUNT<=H2+10,CONST(IF(H6=0,L,REF(L,H6))),DRAWNULL),DOTLINE;

H8:IF(CURRBARSCOUNT<=H2+1,IF(H=HHV(H,9),H,DRAWNULL),DRAWNULL),CIRCLEDOT;

DRAWTEXT(CURRBARSCOUNT=H2+10,H7,'LINE'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,H7,'移动止损线'),COLORYELLOW;

KSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

{K:=SMA(KSV,3,1);

D:=SMA(K,3,1);

DRAWTEXT(CROSS(C,MID中轨) AND CROSS(K,D),L,'↖KD金叉');}

AR1:=REF(CLOSE,1);

AR2:=SMA(MAX(CLOSE-AR1,0),7,1)/SMA(ABS(CLOSE-AR1),7,1)*100;

DRAWTEXT(FILTER(REF(AR2,1)<20 AND AR2>REF(AR2,1),5),L*0.99,'↖特准抄底'),COLORGREEN;

BIAS1:=(C-MA(C,6))/MA(C,6)*100;

BIAS2:=(C-MA(C,12))/MA(C,12)*100;

BIAS3:=(C-MA(C,24))/MA(C,24)*100;

BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;

乖离:=MA(BIAS,3);

DRAWTEXT(CROSS(BIAS,乖离) AND 乖离<-9.5,L*0.96,'↖红柱抄底'),COLORRED;}

RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=((3 * K) - (2 * D));

X1:=(((((3 * CLOSE) + HIGH) + LOW) + OPEN) / 6);

X2:=EMA(X1,10);

AA10:=MA(CLOSE,8),COLORYELLOW ;

RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

K24:=SMA(RSV24,3,1);

D24:=SMA(K24,3,1);

J24:=((3 * K24) - (2 * D24));

VARD:=((((OPEN + LOW) + HIGH) + CLOSE) / 4);

支撑:=EMA(VARD,5);

均线:=MA(CLOSE,16);

阻挡:=(SMA(HIGH,21,2) * 1.05);

A:=(3*C+L+O+H)/6;

B:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)

+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+

REF(A,20))/210;

{STICKLINE(B>REF(B,1),REF(B,1),B,4,0),COLORYELLOW;

STICKLINE(B<=REF(B,1),REF(B,1),B,4,0),COLORGREEN;}

MA3:=MA(C,3);

MA13:=MA(C,13),COLORGREEN;

{IF(MA13>REF(MA13,1),MA13,1),COLORRED;

IF(MA13<REF(MA13,1),MA13,0),COLORYELLOW;

DRAWICON(C>MA3 AND C>MA13 AND MA13>REF(MA13,1)

AND REF(C,1)<MA13,L*0.99,9);}

VAR1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14)))),;

VAR2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));

VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

DIR1:=ABS(CLOSE-REF(CLOSE,5));

VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);

ER1:=DIR1/VIR1;

CS1:=ER1*(0.8-2/8)+2/8;

CQ1:=CS1*CS1;

DIR2:=ABS(CLOSE-REF(CLOSE,10));

VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);

ER2:=DIR2/VIR2;

CS2:=ER2*(0.8-2/24)+2/24;

CQ2:=CS2*CS2;

STICKLINE(VAR2 < MA(VAR3,8),LOW,HIGH,0,1),COLORBLUE;

STICKLINE(VAR2 > MA(VAR3,8),LOW,HIGH,0,1),COLORRED;

{ Gupang.com 股-旁-网_飞狐股票指标公式}

STICKLINE(((OPEN>CLOSE)AND(VAR2<MA(VAR3,6))),(CLOSE-0.03),OPEN,8,0),COLORBLUE;

STICKLINE(((OPEN<CLOSE)AND(VAR2<MA(VAR3,6))),CLOSE,OPEN,8,1),COLORBLUE;

STICKLINE(((OPEN>CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,(CLOSE-0.03),8,0),COLORRED;

STICKLINE(((OPEN<CLOSE)AND(VAR2>MA(VAR3,6))),OPEN,CLOSE,8,1),COLORRED;

DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW - (LOW*0.02)),4);

DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH+(HIGH*0.02)),5);

{波浪顶底}

TY:=C;

HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);

LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);

E:=REF(C,BARSLAST(HD));

F:=REF(C,BARSLAST(LD));

TT1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;

T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);

波浪顶:IF(TT1,E,E),COLORFF00FF,POINTDOT,LINETHICK2;

STICKLINE(TT1,E,E,9,0),COLORFF00FF;

波浪底:IF(T2,F,F),COLOR80FF00,POINTDOT,LINETHICK2;

飞狐智能看盘主图指标公式完毕,希望对您有所帮助,更多选股公式,敬请关注红股网发布。

以上是由“红股网”整理的“飞狐智能看盘主图指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱hongguwang@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。