首页 > 选股公式 > 飞狐公式 > 正文

飞狐红帆资金指标公式(选股公式/源码)

2020-06-30 04:08:48 来源:网络

最近看到很多股民说需要飞狐公式里关于飞狐红帆资金指标公式,下面红股网整理一份《飞狐红帆资金指标公式(选股公式/源码)》,希望让您对飞狐公式有所认识。

X:=2012;

INPUT:X(2008,1990,2020); 换手率:IF(CAPITAL=0,INDEXV/ESTDATA(12),VOL/FINANCE(7)),PRECISION2,LINETHICK0;

variable:wday[7]='星期六';wday[1]:='星期日';wday[2]:='星期一';

wday[3]:='星期二';wday[4]:='星期三';wday[5]:='星期四';wday[6]:='星期五';

fy:=YEAR;fm:=MONTH;fd:=DAY;wd:=WEEKDAY;p:=SYSPARAM(1);BB:=BARPOS;

str1:=''+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'+NUMTOSTR(fd[p],0)+'日 '+wday[wd[p]+1];

SJ:=OPENMINUTES(CURRENTTIME)>1 and OPENMINUTES(CURRENTTIME)<239;

qj0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);jj:=(HIGH+LOW+CLOSE)/3;

特大:IF(CAPITAL=0,qj0*(jj-MIN(CLOSE,OPEN)),qj0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW))),PRECISION0,COLOR0000FF,LINETHICK;

大户:IF(CAPITAL=0,qj0*(MIN(OPEN,CLOSE)-LOW),qj0*IF(HIGH=LOW,1,(jj-MIN(CLOSE,OPEN)))),PRECISION0,COLORFF00FF,LINETHICK;

中户:IF(CAPITAL=0,qj0*(HIGH-MAX(OPEN,CLOSE)),qj0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE)))),PRECISION0,COLOR00FF00,LINETHICK;

散户:IF(CAPITAL=0,qj0*(MAX(CLOSE,OPEN)-jj),qj0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-jj))),PRECISION0,COLORFF6600,LINETHICK;

总1:=(特大+大户)-(中户+散户);总:=vol;

ww:=SYSPARAM(2);n1:=SYSPARAM(3);nn:=n1-ww+1;hh:=HHV(总,nn);ll:=LLV(总,nn);

ZG:=hh[n1];ZD:=ll[n1];中0:=ZD+(ZG-ZD)*0.5;中:=中0*0.05;CM:=SUM(总1,25);

ZJ:=REF(总1,1);ZSB:=(总1-REF(总1,1))/总*100;

ZSA:=cm/IF(STKTYPE=0,SUM(VOL,25),IF(STKTYPE=13,SUM(VOL,10),CAPITAL));

cc:=REF(CLOSE,BARSLAST(fm>REF(fm,1)));主力成本:=(cc*(特大+大户)*100)/(特大+大户)/100;

DF1:=EMA(CLOSE,12)-EMA(CLOSE,26);DA1:=EMA(DF1,9);

qj6:=df1>da1 and da1<0;qj7:="kdj.k">"kdj.d" and "kdj.d"<30;

qj8:=df1<da1;qj9:="kdj.k"<"kdj.d" and "kdj.k">80;

w1:=SUM(大户,5)+SUM(特大,5);w2:=SUM(散户,5)+SUM(中户,5);

量振1:=特大>大户 and 大户>散户;量振2:=特大<散户 and 大户<散户;

标振1:=qj6 and qj7;标振2:=qj8 and qj9;

a:=w1-w2;a0:=IF(a>0,a,0);b0:=IF(a<0,a,0);

STICKLINE(总1<0,0,-总1+总/2,8,0),ColorFF4400;STICKLINE(总1<0,0,-总1+总/2,6,0),ColorFF8800;

STICKLINE(总1<0,0,-总1+总/2,3,0),ColorFFaa00;STICKLINE(总1<0,0,-总1+总/2,1,0),ColorFFcc00;

STICKLINE(总1>0,0,+总1+总/2,8,0),Color000044;STICKLINE(总1>0,0,+总1+总/2,6,0),Color000088;

STICKLINE(总1>0,0,+总1+总/2,3,0),Color0000aa;STICKLINE(总1>0,0,+总1+总/2,1,0),Color0000cc;

STICKLINE(a0,0,a0,8,0),Color000044;STICKLINE(a0,0,a0,5,0),Color000088;

STICKLINE(a0,0,a0,3,0),Color0000aa;STICKLINE(a0,0,a0,1,0),Color0000cc;

STICKLINE(b0,0,-b0,8,0),Color004400;STICKLINE(b0,0,-b0,5,0),Color008800;

STICKLINE(b0,0,-b0,3,0),Color00aa00;STICKLINE(b0,0,-b0,1,0),Color00cc00;

STICKLINE(BB=ww,中*0.2,中*9.2,(散户[P]/总*200)*1.02,1),COLORWHITE,LINETHICK2;

STICKLINE(BB=ww,中*0.8,中*8.6,散户[P]/总*200,0),COLORFF8800;

STICKLINE(BB=ww,中*10.2,中*19.2,(中户[P]/总*200)*1.02,1),COLORWHITE,LINETHICK2;

STICKLINE(BB=ww,中*10.8,中*18.6,中户[P]/总*200,0),COLORFF00FF;

STICKLINE(BB=ww,中*20.2,中*29.2,(大户[P]/总*200)*1.02,1),COLORWHITE,LINETHICK2;

STICKLINE(BB=ww,中*20.8,中*28.6,大户[P]/总*200,0),COLOR0088FF;

STICKLINE(BB=ww,中*30.2,中*39.2,(特大[P]/总*200)*1.02,1),COLORWHITE,LINETHICK2;

STICKLINE(BB=ww,中*30.8,中*38.6,特大[P]/总*200,0),COLOR0000FF;

STICKLINE(BB=ww-28,中*-0.2,中*40,500,0),COLOR000000;

DRAWTEXTEX(CLOSE,1,420,0,str1),ColorffFF00;

DRAWTEXTEX(CLOSE,1,200,0,STKLABEL+' '+STKNAME+''),ColorffFF00;

DRAWTEXT(BB=ww,中*36,'特大:'+NUMTOSTR(特大[P]/总*100,2)+' %'),COLOR00FF00;

DRAWTEXT(BB=ww,中*26,'大户:'+NUMTOSTR(大户[P]/总*100,2)+' %'),COLOR00FF00;

DRAWTEXT(BB=ww,中*16,'中户:'+NUMTOSTR(中户[P]/总*100,2)+' %'),COLOR00FF00;

DRAWTEXT(BB=ww,中*6,'散户:'+NUMTOSTR(散户[P]/总*100,2)+' %'),COLOR00FF00;

周趋势:MA(a0,5),ColorFF00FF,PRECISION0;

平滑值:WMA(周趋势,5),Color00FF00,PRECISION0;

买:量振1 and 标振1 and 周趋势>平滑值,Color0000FF,LINETHICK;

卖:量振2 and 标振2 and 周趋势<平滑值,Color00FF00,LINETHICK;

VERTLINE(买),COLORff00ff,POINTDOT;

VERTLINE(卖),COLOR00ff00,POINTDOT;

DRAWTEXTEX(CLOSE,1,200,130,'主力成本:'+NUMTOSTR(主力成本[p],2)),COLOR00FF00;

DRAWTEXTEX(CLOSE,1,420,130,'主力筹码占流通:'+NUMTOSTR(IF(ZSA>0,ZSA[P]*100,0),2)+' %'),COLOR00FF00;

DRAWTEXTEX(CLOSE,1,720,130,'较昨日增减:'+NUMTOSTR(ZSB[P],2)+' %'),COLOR00FF00;

DRAWTEXTEX(c and 总1[P]<0,1,720,0,'散户主买 主力主卖'),COLORffee00;

DRAWTEXTEX(c and 总1[P]>0,1,720,0,'主力主买 散户主卖'),COLOR0000ff;

周仓:=SUM(总1,5);月仓:=SUM(总1,25);年仓:=SUM(总1,240);上周:=REF(周仓,1);上月:=REF(月仓,1);

上年:=REF(年仓,BARSLAST(fy=X));周增:=周仓-上周;月增:=月仓-上月;年增:=年仓-上年;

EXPLAIN(1,'***【理想=**=论坛】***'),color00EEFF;

EXPLAIN(1,'==================================='),colorwhite;

EXPLAIN(1,'今日增减:'+NUMTOSTR((总1[p]*100)/10000,2)+' 万股'),COLOrffff00;

EXPLAIN(1,'昨日增减:'+NUMTOSTR(zj[p]*100/10000,2)+' 万股'),ColorFF8B00;

EXPLAIN(1,'==================================='),colorwhite;

EXPLAIN(1,'周仓:'+NUMTOSTR(周仓[p]*100/10000,2)+' 万股'),COLORred;

EXPLAIN(1,'上周:'+NUMTOSTR(上周[p]*100/10000,2)+' 万股'),COLORred;

EXPLAIN(1,'增减:'+NUMTOSTR(周增[p]*100/10000,2)+' 万股'),COLORred;

EXPLAIN(1,'==================================='),colorwhite;

EXPLAIN(1,'月仓:'+NUMTOSTR(月仓[p]*100/10000,2)+' 万股'),COLORFF00FF;

EXPLAIN(1,'上月:'+NUMTOSTR(上月[p]*100/10000,2)+' 万股'),COLORFF00FF;

EXPLAIN(1,'增减:'+NUMTOSTR(月增[p]*100/10000,2)+' 万股'),COLORFF00FF;

EXPLAIN(1,'==================================='),colorwhite;

EXPLAIN(1,'年仓:'+NUMTOSTR(年仓[p]*100/10000,2)+' 万股'),COLOR00EE00;

EXPLAIN(1,'上年:'+NUMTOSTR(上年[p]*100/10000,2)+' 万股'),COLOR00EE00;

EXPLAIN(1,'增减:'+NUMTOSTR(年增[p]*100/10000,2)+' 万股'),COLOR00EE00;

EXPLAIN(1,'==================================='),colorwhite;

飞狐红帆资金指标公式完毕,希望对您有所帮助,更多选股公式,敬请关注红股网发布。

以上是由“红股网”整理的“飞狐红帆资金指标公式(选股公式/源码)”全部内容,如稿件涉及版权等问题,请与我们联系删除或处理,客服邮箱hongguwang@qq.com,稿件内容仅为传递更多信息之目的,不代表本网观点,亦不代表本网站赞同其观点或证实其内容的真实性。